La Powerbank est uniquement compatible avec le VanMoof S3 & X3. Pour utiliser la Powerbank, vous devez mettre à jour le firmware vers la version 1.6.8 ou supérieure. 


Vous ne pouvez malheureusement pas utiliser la Powerbank avec les modèles Electrified S2 & X2 ou les anciens modèles VanMoof car l'électronique n'est pas compatible.